• 欢迎访问水熊虫网站,这里是我个人的工作博客,内容大多是遇到问题完善后,会在这里进行总结归纳内容! QQ群
  • 网站导航中的友情链接专栏上线,更新的都是自己这三年整理的一些东西,感兴趣可以看看!
  • 你所浪费的今天,是昨天死去的人奢望的明天。你所厌恶的现在,是未来的你回不去的曾经!

kangle在linux下自定义错误版及kanle3.5.16升级方法

Kangle环境 WaterBear 来源:kangle在linux下自定义错误版及kanle3.5.16升级方法 1年前 (2019-09-13) 104次浏览 已收录 扫描二维码

     kangle在linux下自定义错误版,错误版都采用了黑色小河的方法,把40x和50x错误文件放到你服务器/vhs/kangle/error/目录。支持centos、ubuntu、debian等系统,新版加强了安全,如果需要访问3311还需要编辑/vhs/kangle/etc/config.xml文件,把<listen ip='127.0.0.1' port='3311' type='manage' />改为<listen ip='*' port='3311' type='manage' />或指定访问的IP,安装完成后默认用户名admin,密码kangle。
你可以手动升级或一键升级,一键升级脚本添加error错误目录

一键安装或升级脚本:yum install wget curl -y;wget http://www.osyum.com/yum/kangleup.sh -O kangleup.sh;sh kangleup.sh

以下是手动升级
先安装自定义错误版3.5.16

centos先安装zip unzip

yum install zip unzip -y

debian安装 

apt install unzip zip -y

ubuntu安装

apt-get install zip unzip -y

接下来重新安装kangle,不影响数据

yum -y install wget make automake gcc gcc-c++ pcre-devel zlib-devel sqlite-devel openssl-devel libaio-devel
/vhs/kangle/bin/kangle -q
wget http://yum.osyum.com/linux/kangle/kangle-3.5.16.tar.gz
tar -zxvf kangle-3.5.16.tar.gz
cd kangle-3.5.16
./configure --prefix=/vhs/kangle --enable-vh-limit --enable-disk-cache --enable-ipv6 --enable-ssl
make
make install
/vhs/kangle/bin/kangle

自定义错误文件

400.html
401.html
403.html
404.html
405.html
406.html
407.html
412.html
414.html
500.html
503.html
504.html

本站也提供了一份,当然你可以自定义
需要服务器安装zip unzip,如你是本站安装easypanel,可以不用在安装zip

wget http://yum.osyum.com/linux/kangle/error.zip
mkdir -p /vhs/kangle/error
unzip error.zip -d /vhs/kangle/error
/vhs/kangle/bin/kangle -q
/vhs/kangle/bin/kangle

完成 

更新日志

2019.06.11更新至kangle-3.5.16

2019.05.15更新了支持freebsd12



WaterBear , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:kangle在linux下自定义错误版及kanle3.5.16升级方法
喜欢 (0)
[[email protected]]
分享 (0)