• 欢迎访问水熊虫网站,这里是我个人的工作博客,内容大多是遇到问题完善后,会在这里进行总结归纳内容! QQ群
  • 网站导航中的友情链接专栏上线,更新的都是自己这三年整理的一些东西,感兴趣可以看看!
  • 你所浪费的今天,是昨天死去的人奢望的明天。你所厌恶的现在,是未来的你回不去的曾经!

安装Percona XtraBackup报错

未分类 WaterBear 4周前 (09-25) 30次浏览 已收录 扫描二维码

具体报错如下:

[[email protected] www]# yum localinstall percona-xtrabackup-24-2.4.24-1.el7.x86_64.rpm 

上次元数据过期检查:2:37:30 前,执行于 2021年09月24日 星期五 21时24分24秒。

错误:

 问题: conflicting requests

  - nothing provides libgcrypt.so.11()(64bit) needed by percona-xtrabackup-24-2.4.24-1.el7.x86_64

  - nothing provides libgcrypt.so.11(GCRYPT_1.2)(64bit) needed by percona-xtrabackup-24-2.4.24-1.el7.x86_64

(尝试添加 '--skip-broken' 来跳过无法安装的软件包 或 '--nobest' 来不只使用最佳选择的软件包)

        检查才发现,下载版本不对导致报错,默认下载成CentOS7版本的软件,查看系统默认是CentOS8版本的,重新下载安装就正常了!

CentOS7 2.4版本下载链接:https://downloads.percona.com/downloads/Percona-XtraBackup-2.4/Percona-XtraBackup-2.4.24/binary/redhat/7/x86_64/percona-xtrabackup-24-2.4.24-1.el7.x86_64.rpm

CentOS8 2.4版本下载链接:https://downloads.percona.com/downloads/Percona-XtraBackup-2.4/Percona-XtraBackup-2.4.24/binary/redhat/8/x86_64/percona-xtrabackup-24-2.4.24-1.el8.x86_64.rpm

其他版本下载:https://www.percona.com/downloads/Percona-XtraBackup-2.4/LATEST/


WaterBear , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权
转载请注明原文链接:安装Percona XtraBackup报错
喜欢 (4)
[[email protected]]
分享 (0)